본문 바로가기

Spring

Android 핫스팟(테더링)을 스마트하게 쓰기위한 모와(Mowa) 개발기 모와(Mowa) 서비스 소개 보기 핫스팟 일명 테더링 이란 무엇일까요?사전적 의미로 딱딱하게 말하면 아래와 같습니다. 테더링(영어: tethering)은 인터넷 접속이 가능한 기기를 이용하여, 다른 기기에도 인터넷에 접속할 수 있게 해주는 기술이다. 블루투스 무선 기술이나 USB 케이블 등으로 두 기기를 연결하여 사용할 수 있으며, 이때 인터넷 접속이 가능한 기기가 다른 기기의 모뎀 역할을 하게 된다.- 위키피디아 한마디로 요약하면 3G/LTE가 되는 휴대폰의 데이터를 사용할 수 있게 하는 기능!즉, 휴대폰의 3G/LTE 데이터를 Wi-Fi로 바꿔주는 기능이며 다른 기기에서 인터넷을 할 수 있게 하는것이죠!근데 이게 응근 사용하기 불편합니다 이기능 자체를 모르시는 분들도 많구요! 그래서! 생각했습니다(지.. 더보기
[Spring] 스프링에서 sitemap.xml 및 robots.txt 처리하기 스프링 프레임워크로 사이트를 개발하여 sitemap 및 robots.txt 를 처리해야할 필요가 있을때 아래처럼 구성하면 유기적으로 관리가 가능합니다.sitemap.xml 에 신규 컨텐츠를 지속적으로 추가해주어야 구글검색등에 반영이 될 수 있습니다 SitemapController.java@Controller public class SitemapController { @RequestMapping(value = "/sitemap.xml", method = RequestMethod.GET) @ResponseBody public XmlUrlSet main() { XmlUrlSet xmlUrlSet = new XmlUrlSet(); create(xmlUrlSet, "", XmlUrl.Priority.HIGH); .. 더보기
[MongoDB] Spring 4.x + MongoDB 3.x 연동하기 지난번에 Spring + MongoDB 연동을 포스팅했었는데요, 그때는 Spring 3.2.2 기준에 MongoDB 2.6 버전이였습니다.다시 구성하려고 보니 스프링4.x + 몽고디비 3.x 구성시에는 조금 달라진 부분이 있더군요제일큰게 몽고디비가 버전이 3대로 올라오면서 인증방식 변화로 예전처럼 해서는 접속이 안되는 문제가 있었습니다.[ Spring 3.2.2 + MongoDB 2.6 조합 포스팅 보기 ] 1. 개발환경- JAVA 8 - Tomcat7 - Spring Framework 4.1.7.RELEASE - Spring-data-mongodb 1.8.0.RELEASE org.springframework.data spring-data-mongodb 1.8.0.RELEASE org.mongodb mo.. 더보기
[Spring] 스프링3.x에서 mongoDB연동하기 스프링에서 몽고DB를 사용하려고 삽질을 겁나했다...일단 스프링을 본격적으로 사용한지가 얼마되지 않아서 많이 해맸는데, 해보고 나니 진짜 별거없다... 1. pom.xml 에 mongodb driver추가 org.mongodb mongo-java-driver 2.7.1 org.springframework.data spring-data-mongodb 1.0.1.RELEASE 2. config.xml 에 아래내용추가 - 저같은 경우는 mybatis와 함께 사용중이기 때문에 mybatis_config.xml 에 함께 추가해서 사용중입니다. 각자에 맞게 잡으시면됩니다 3. 쿼리날려보기( find )Query query = Query.query(Criteria.where("검색할key").is(검색할단어)); q.. 더보기
Spring Framework 3.2.x 2015년 까지만 유지보수, 2016년부터는 지원 중단한다네요 스프링 공식 홈페이지에서 언급된 내용입니다.아래 주소에서 확인하실 수 있습니다 http://spring.io/blog/2014/12/30/spring-framework-4-1-4-4-0-9-3-2-13-released 정확한 내용은 Spring3.2.x 버전대에 대한 유지보수를 2015년 까지만 제공하고 2016년 부터는 제공하지 않겠다는 거구요즉, Spring 4.x 를 사용하라는 거죠~ 이참에 Srping4.0 을 써볼까요?ㅎSpring4.0의 최소 요구 사항은 JDK6+ , 서블릿 3.0 이구요스프링 에서 최초로 JDK8 을 지원하는 버전이기도 합니다~ 더보기